We're here to help

Java version mismatch error

If you receive a Java version mismatch error message, it is likely because you are using a version of Java that is different than what your version of Provar supports via Apache Ant.

In some instances, you need to use an older version of Java in order for Provar to function correctly.

 

Error message


Java Version Mismatch, please use Java version less than 1.8.0.201. Actual version: x.x.x_xxx.

 

How can I fix this issue?


Step 1: Uninstall your current version of Java.

Step 2: Install a compatible version of Java. Compatible versions include: 1.8.0.162, 1.8.0.172, 1.8.0.201, 1.8.0.211, 1.8.0.221.

Step 3: Update the JAVA_HOME environment variable that is associated with your new Java version location.

Your Provar tests should now function correctly.